Exchange 2010 SP1 – Content Indexing function ‘CISearch::EcGetRowsetAndAccessor’ received an unusual and unexpected error code from MSSearch.

Exchange 2010 may report the following error in your eventlog:

Log Name:      Application
Source:        MSExchangeIS Mailbox Store
Event ID:      9877
Task Category: Content Indexing
Level:         Error
Computer:      EXCH1
Description:
Content Indexing function ‘CISearch::EcGetRowsetAndAccessor’ received an unusual and unexpected error code from MSSearch.
Mailbox Database: Database1
Error Code: 0x80041606

Several blogs on the internet suggest diverse solutions for this problem. Here’s my suggestion to solve this problem:

  1. Rebuild the Search Index. This involves no downtime. To rebuild, do the following:
    • Open The Exchange Management Shell
    • Go to the scripts directory ( command: cd $exscripts )
    • Run command .\ResetSearchIndex.ps1 -Force –All
  2. If step 1 doesn’t help, upgrade to the latest rollup. At the time I’m writing this post, this is SP1 rollup 5. Many blogs report that rollup 4 and later resolve the Search issue.

Note: If you’re planning to upgrade your Exchange Server, don’t forget to disable your Forefront Protection (if installed…). In the EMS, run fscutility /disable. After you’ve upgraded your server, run fscutility /enable

Leave a Reply

3 Comments on "Exchange 2010 SP1 – Content Indexing function ‘CISearch::EcGetRowsetAndAccessor’ received an unusual and unexpected error code from MSSearch."

Notify of
avatar
Sort by:   newest | oldest | most voted
John
Guest

Restarting the Exchange Search Service fixed my issue.

Sonat
Guest

This issue has been solved in Rollup 6
http://support.microsoft.com/kb/2616127

Ian C.
Guest

@sonat – and yet I still have this issue in Rollup 14, five years later.

wpDiscuz